Installation Instructions

Installation
As a prerequisite, install the Windows Operating System with IIS installed and ASP.NET enabled on a
PC/Server.

Setup
CALLTRAK installation is performed through an installation wizard downloaded (or supplied) by
Theodore Software Consultants. It is recommended to save the installation wizard in a folder such as
C:\Program Files\TSC\CALLTRAK\install
The installation wizard is typically named
AUSSSSetup.exe or AUS64SSSetup.exe
where
AUS is the Country compatible for the installation
SS – SQL Server
if installation is required for a 64 bit operating system 64 will appear in the installation wizard file
name. Always run the installation wizard 'as administrator' and follow the instructions.

When prompted for the installation password, enter the password as supplied by Theodore Software
Consultants (manufacturers of CALLTRAK). Then follow the instructions.

The installation script will install the CALLTRAK application files and CALLTRAK services

The following dialog appears, click Next.

Check the installation parameters and if OK, click on Install.

The file installation commences. After the files have completed downloading, the following appears.

Click on Next and you are prompted for the additional applications required in the installation. If you
already have SQL Server or Management studio or other of the required additional applications
installed, you may un-tick the options and click Finish.

The installation will also make a default entry in the Data Sources (ODBC) for CALLTRAK. The default
CALLTRAK installation assumes the database server name is 'localhost'. Therefore if the SQL Server
database server instance name is not localhost, you will need to modify the config files and the ODBC
connection to use the appropriate SQL Server instance name. You can modify the config files after

the installation is completed and the SQL server database has been configured. Refer to Modifying
the config files and ODBC connection.
If you are installing a SQL Server (or Express) instance, during the installation process, select
Mixed Mode (Windows Authentication and SQL Server Authentication) when prompted. You
will be asked to enter the sa credentials. Enter the sa password and confirm password. Remember to
write down the password. Then continue by clicking next. On the next screen, Tick Add user to the
SQL Server Administrator role. The SQL Server database will be configured in the next stage in
SQL Server configuration.

SQL Server configuration
These steps involve configuring SQL Server to install and operate the CALLTRAK database. Normally
a Database Administrator will perform the following steps.
Prior to commencing to attach the CALLTRAK database to the SQL Server instance, ensure full
security access to the folder the CALLTRAK database resides in. The folder will need write access
permissions.
1. To install the CALLTRAK database, a database management tool is required..
We recommend the use of SQL Server Management Studio and it is included in the CALLTRAK
installation wizard. This may be downloaded from www.calltrak.com.au/Support.html website or the
appropriate link from Microsoft pages. First install SQL Server Management Studio prior to
continuing.
Start SQL Server Management Studio and log on using Windows Authentication
If you can not connect to the SQL Server instance and are receiving a
Cannot connect to ‘Servername’ error 28.
Please refer to SQL Server error 28 Enabling Services
Right click Databases and select Attach.
The Attach Databases dialog appears
Click on the Add button and browse to the CALLTRAK.mdf database. The database will be found in
the folder CALLTRAK was installed in. The default folder (for 32bit installation) is C:/Program
Files/TSC/calltrak/DB. Select the database CALLTRAK.mdf and click OK
The database will appear

Database name must be
CALLTRAK

Make sure the Attach As has the name of CALLTRAK. You can change this by clicking on the name
and changing appropriately. Then click OK.
You will see the CALLTRAK database available

New Query button

Calltrak DB
available

Security option

SQL Server instance

If you see an error '5 (Access is denied)' message, refer to SQL Server error 5 Access is denied and
retry this step
If you see an error SqlError: CREATE DATABASE permission denied in database ‘master’.
(Microsoft.SqlServer.Express.Smo)’ refer to Create database permissions denied in database
master and retry this step.
If you see an error and the Calltrak database displays CALLTRAK (Read only), refer to CALLTRAK
Database displaying CALLTRAK (Read only) This will have been caused by the database folder not
having write permissions.
2. You may configure Calltrak to use the sa user account or alternatively create a user called calltrak
If you use the sa user account, then skip to step 4.
Expand the Security option and right click Logins and select New Login
The 'Login - New' dialog appears.
Enter the following
Login name: calltrak
select the SQL Server authentication radio button
Password: password
Confirm password: password
Click on the checkbox Enforce password Policy so that it is UNTICKED (UNCHECKED)
In the Default Database dropdown list, select calltrak
Default database: CALLTRAK
and click OK
The CALLTRAK user is created.
3. Need to recreate the CALLTRAK user for database access
Click on the New Query button to start the SQL query analyser.
enter the following SQL query.
USE CALLTRAK

GO
EXEC sp_change_users_login 'Auto_Fix', 'CALLTRAK', NULL, 'password'
GO
click on the execute button.
4. If you have already configured SQL Server to have both SQL Server and Windows Authentication,
skip to step 7. Need to configure SQL Server to have both SQL Server and Windows Authentication
mode access, so that the CALLTRAK user can login.
Right Click on the SQL Server instance and select properties
The server properties page appears
select
Security page
Click on SQL Server and Windows Authentication mode
Click on None at the Login auditing section
then click OK
You may close and exit SQL Server Management studio.
5. Need to define an alias for localhost for the SQL Server machine.
Go to control panel > Administrative tools > Computer management: Open it
Expand services and Application > SQL Server Configuration Manager > SQL Native client
configuration
Check the Aliases option
Then add an alias for localhost
Alias Name: localhost
Port No: 1433
Protocol: TCP/IP
Server: 'Whatever the SQL Server instance name is’

The Server name is the same as entered in SQL Server management studio when gaining access to
the CALLTRAK database.
The default Port No. is 1433 but can be changed
Click Apply then OK. You will see the localhost alias displayed.
6. Need to restart the SQL Server service
Go to SQL Server 2005 Services
Right click on the SQL Server service and select restart
This will stop/start the SQL Server service
Also restart the SQL Server Browser
7. When logging into SQL Server Management Studio, log on using SQL Server Authentication. You
may log in using the default SQL Server name or via the localhost server name created in steps 5-6.
At the Login prompt, enter either the sa account or the calltrak user created in step 2. In the
password field, enter either the password created for the calltrak user (in step 2) or enter the sa
password.
* It is important to note the following 1. SQL Server instance server name 2. Login id 3. Password.
These credentials will be used to configure the .config files required by Calltrak to connect to the SQL
Server database. See Modifying the config files and ODBC connection.

SQL Server instance name
Eg. localhost

On successful entry, the following appears.

Calltrak Database

You will be able to see the CALLTRAK database displayed above. After the database is visible, refer to
Modifying the config files and ODBC connection. If you can not see CALLTRAK as above, please re
read this section or contact CALLTRAK support through the website www.calltrak.com.au

Modifying the config files and ODBC connection
We will assume that the server name is localhost, however, the server name is the same as used to
connect to the CALLTRAK database through SQL Server Management studio. If the server name is
different to localhost, you will need to modify the following config files. The config files are used by
the CALLTRAK services and web pages to identify how to connect to the database.

Filename (and default location – if 64bit, Program Files (x86))

Used by

C:/Program Files/TSC/CALLTRAK/Collector.exe.config

Collector service for collecting data

C:/Program Files/TSC/CALLTRAK/Coster.exe.config

Coster service for costing data

C:/Program Files/TSC/CALLTRAK/utilities/CalltrakRegn.exe.config CALLTRAK Licensing system
C:/inetpub/wwwroot/CALLTRAK/CalltrakRepScheduler.exe.config

Report scheduler service

C:/inetpub/wwwroot/CALLTRAK/recoster.exe.config

Recoster service

C:/inetpub/wwwroot/CALLTRAK/web.config

Web pages

Open the relevant config file using an editor such as notepad and search for the <appSettings>
section, then apply changes to the fields as indicated in the diagram below if required.
Collector.exe.config file server name and connection parameters are found in the following line of
the C:/Program Files/TSC/CALLTRAK/Collector.exe.config file

Typically, the only field required to be changed is the server name. Edit the server name from
localhost to the SQL Server database instance server name. The database server name can be found
from SQL Server Management studio (SQL Server Express).
Coster.exe.config file server name and connection parameters are found in the following line of the
C:/Program Files/TSC/CALLTRAK/Coster.exe.config file
SQL Server database

Change servername from localhost to the correct DB Servername.
Also, uid and pwd as required to connect to SQL Server DB

<appSettings>
<add key="ConnectionString" value="server=localhost;uid=CALLTRAK;pwd=password;database=CALLTRAK;MultipleActiveResultSets=True"/>
<add key="RawDataDirectory" value="C:\Program Files\TSC\CALLTRAK\"/>
</appSettings>

CalltrakRepScheduler.exe.config file server name and connection parameters are found in the
following line of the C:/inetpub/wwwroot/CALLTRAK/CalltrakRepScheduler.exe.config file
SQL Server database
<appSettings>

Change servername from localhost to the correct DB Servername.
Also, uid and pwd as required to connect to SQL Server DB

<add key="ConnectionString" value="server=localhost;uid=CALLTRAK;pwd=password;database=CALLTRAK;MultipleActiveResultSets=True"/>
<add key="SSODBCServerName" value="CALLTRAK"/>
<add key="SSDBName" value="CALLTRAK"/>
<add key="SSUid" value="CALLTRAK"/>
<add key="SSPassword" value="password"/>
</appSettings>

Change SSUid and SSPassword to the
Credentials required by SQL Server DB

Web.config file server name and connection parameters are found in the following line of the
C:/inetpub/wwwroot/CALLTRAK/web.config file
SQL Server database – Change the server name from localhost to the SQL Server server name
<add name="SQLServerConnString" connectionString="server=localhost;uid=CALLTRAK;pwd=password;database=CALLTRAK"
providerName="System.Data.SqlClient"/>

Change servername from localhost to the correct DB Servername.
Also, uid and pwd as required to connect to SQL Server DB

ODBC Connection

Crystal reports uses an ODBC connection to connect to the database. The default database server
name configured by CALLTRAK in the ODBC connection is localhost. To change these setting perform
the following. Open Data Sources (ODBC)
Administrative Tools > Data Sources (ODBC)
and click on the System DSN tab.

SQL Server uses the CALLTRAK ODBC connection
Click on Data source name to select it, then click on Configure. The following appears

Change servername from localhost
To the correct DB Servername

You will see a Server dropdown list. Click on the SQL Server database instance or enter the database
instance manually. Then click Next
The following screen appears

CALLTRAK is configured to connect with SQL Server authentication, so please click the option
With SQL Server authentication using a login ID and password entered by the user.
Enter the login ID and password for connecting to the SQL Server database. The credentials will be
the same as when the CALLTRAK database was attached to the SQL Server instance.
Click Next.
The following appears

The Database should be CALLTRAK, if not, change so that the Database is CALLTRAK. Click Next.
The following appears.

Click Finish and test the connectivity by clicking on Test Data Source. If connection is successful. The
following will appear.

Click OK and any Apply buttons. Click on the User DSN tab and perform the same above steps.

Configuring IIS
CALLTRAK is a web based application and requires Internet Information Services (IIS) with ASP.Net
installed and configured correctly. IIS is responsible for allowing a user to browse to the CALLTRAK
application. Typical browsers include Internet Explorer or Google Chrome.
IIS with ASP.NET is installed during the Windows Operating system installation or added as a
program feature. As part of the IIS installation, remember to select and enable ASP.NET.
If you are having difficulties starting the CALLTRAK application (ie browsing to it), then the problem
will be IIS related and the IIS configuration will need to be rectified.
First, confirm that IIS and ASP.NET has been installed with the OS. You will need the Windows
Installation disk to install IIS if IIS has not been installed. If IIS is not installed, you will not be able
to browse to the CALLTRAK application.
To confirm whether IIS is installed, go to
Control panel > Add or Remove Programs > Add/Remove Windows Components
and check whether both IIS and ASP.NET are ticked and enabled. If they are not enabled, IIS AND

ASP.NET need to be installed. The Windows CD may be required. Follow the installation instructions.

On Operating System below Windows Server 2008
To Configure IIS Control panel > Administrative tools > Internet Information Services
Open Default Web Site, right click and go to New. Then browse to C:\Inetpub\wwwroot and make a
new folder called CALLTRAK (if not already present)
Right click the CALLTRAK folder and click on properties.

Make sure the App name is not greyed
Out. If so, click on create.

In the directory tab, confirm that the Application name CALLTRAK has been created, if it is not
created, click on the button on the right to Create. (In the above screen shot, it has been created).
Then click Apply and OK.
In the documents tab, Add a Logon.aspx entry and move to the top by hitting the up arrow.

In the Directory Security tab, Click Edit button and tick Integrated Windows Authentication then click
the OK button.

On Windows Server 2008 and above
Windows Server 2008 is similarly installed however problems can occur if permissions are not set
correctly. Please always check the permissions if some fault occurs during installation and always
select to 'Run as administrator'.
start > All Programs > Administrative Tools > Server Manager
Right click on Internet Information Services, select Roles
tick on Application Developer
tick on Security

Licensing and Registering CALLTRAK
On installation of CALLTRAK, CALLTRAK will function without any limitations on Extensions or data
collection sites for 30 days with out a license and registration key. After the 30 day period, without
registration, CALLTRAK will cease to process data. Data collection will still occur, however, data will
not be processed and stored in the database. During the 30 day trial period (or prior to licensing),
the following message appears in the CALLTRAK eventlog
CALLTRAK is Unregistered! Trial Period active
If CALLTRAK has not been registered and 30 days have exceeded since installation, the following
message appears in the eventlog and reporting ceases.
CALLTRAK is Unregistered! Please contact support to register Calltrak
CALLTRAK licensing is dependant on the number of collection sites (ie phone systems being collected
from) and the total number of extensions in the Extension database. To monitor the number of
extensions, refer to Table Maintenance > Extensions If licensing has been exceeded and the
extensions have been reduced, to accommodate for licensing, you must reset the file status for each
collection site from formatting to collected. To do this, refer to System Admin > Site Details Please be
aware that a blank site ie “ “ is considered to be a separate site and may affect licensing.
Calltrak licensing is linked to the Ethernet Network Interface Controller (NIC). If the network card
changes, this will impact licensing. Please contact CALLTRAK support on support@calltrak.com.au to
get a new license key.
Licensing occurs via the following CALLTRAK utility found in
C:/Program Files (x86)/TSC/CALLTRAK/utilities/CalltrakRegn.exe
Prior to executing the Registration utility, please configure the CalltrakRegn.exe.config file. Please
refer to Modifying the config files and ODBC connection on how to do so.
Once the CalltrakRegn.exe.config file has been properly configured, execute the Calltrak registration
utility as administrator and supply Calltrak support the key as well as the number of extensions
licensed. If you have exceeded the licensing, please provide the number of extensions in the
database obtained from Table Maintenance > Extensions. There may be an additional licensing fee
incurred if the number of extensions exceeds the licensed number of extensions.
The following screen appears

Please provide Calltrak
Support this key

Provide CALLTRAK support the license key along with the number of extensions and collection sites.
Calltrak support will provide you with the registration key that is entered in Step 2. Once the
registation key is supplied, click Unlock.

Troubleshooting
Installation
SQL Server error 28 Enabling Services
Error Message
When trying to connect to SQL Server Management studio, the following appears whether Windows
Authentication or SQL Server Authentication
Cannot connect to 'Servername'
Additional Information:
A network-related or instance-specific error occurred while establishing a connection to SQL Server.
The server was not found or was not accessible. ... (Provider: SQL Network Interfaces, error:28 Server doesn't support requested protocol)
What it means
Can't connect to SQL Server as no network connection is running.
Solution
SQL Server Configuration Manager > SQL Server 2005 Network Configuration > Protocols for SQLExpress

Right click on TCP/IP and Enable that service.
Need to restart the SQL Server 2005 Service
Go to SQL Server 2005 Services, right click SQL Server (SQLExpress) and click restart

SQL Server error 5 Access is denied
Error message

Restore failed for Server ‘CALLTRAK\SQLEXPRESS’. (Microsoft.SqlServer.Express.Smo)
Additional information
System.Data.SqlClient.SqlError: The operating system returned the error ‘5(Access is denied.)’ while
attempting ‘RestoreContainer::Validate TargetForCreation’ on ….
What it Means
Unable to restore the CALLTRAK database due to access errors
Solution
Launch SQL Server Configuration Manager > SQL Server 2005 Services
then right click on SQL Server (SQLExpress) and select properties
On the Log On tab, click on the Built-in account radio button and change from Network Service (the
default option) to Local System.
After changing the Built-in account to Local System, click on the Apply button and restart the service.
Exit SQL Server Configuration Manager

Create database permissions denied in database master
Error message
When trying to restore the CALLTRAK database into SQL Server Express the following error message may appear
SqlError: CREATE DATABASE permission denied in database ‘master’. (Microsoft.SqlServer.Express.Smo)’
Operating Systems
Windows Server 2008
Solution
This is a SQL Server configuration error. SQL Server needs to have an administrator account identified.

Open SQL Server 2005 Surface Area Configuration and click on Add New Administrator
The default user is displayed on the top right field, User to provision.
On the bottom left pane, you will see the Available privileges
Click on the double arrow (to give all privileges)
Then the OK button

HTTP Error 401.3 appears when trying to display web page
ERROR MESSAGE
HTTP Error 401.3 - Unauthorized
ENVIRONMENT
Win 7
REASON
This is because of authority reasons.
SOLUTION
Administrative Tools > Internet Information Services (IIS) Manager
Expand the CALLTRAK virtual application and open
IIS > Authentication
Then enable
Windows Authentication
This will allow the page to load

Installer unexpected error code 2869
Error message

When trying to install the CALLTRAK collector/coster/scheduler services, the following error message may appear
The installer has encountered an unexpected error installing this package. This may indicate a problem with this
package. The error code is 2869
Operating Systems
Windows Server 2008
Solution
These are the steps to solve the above mentioned problems:
1) Copy the .MSI file to the root directory of your main hard drive (i.e. C:\).
2) Open Windows Notepad.
3) Copy this text into windows notepad:
msiexec /i C:\program_name.msi
(You can write the total path of your .msi file in the system, after msiexec /i.)
4) Replace the text "program_name" in the code that you copied with the actual name of the
5) Click File -> Save As...
Instead of saving it as a .txt file, change the file name to installer.bat.
Save the file to your desktop.
6) On your desktop, right click on the file and select Run as Administrator.
This will run the .msi file properly to install the application in the system.

Requested operation requires elevation
Error message
While trying to install or run an executable the following error message appears
The requested operation requires elevation
Operating Systems

.MSI file .

Windows Server 2008
Solution
This is caused by incorrect permissions settings. When trying to either install or run an executable.
Right click on the file, right click on the properties and look at the securities tab. Make sure there is full control
granted for all users.
After access has been granted, retry installing or executing a service.

CALLTRAK service fails to start
Error message
After installing the CALLTRAK service successfully and then trying to start the service through Administrative Tools
> Services, the CALLTRAK service does not start properly. The service is in a starting state.
Operating Systems
Windows Server 2008
Solution
This is caused by permissions settings. The service can not access the files it requires and therefore hangs while
trying.
Make sure all CALLTRAK folders and files are accessable by the CALLTRAK services.
The following are used by the CALLTRAK collector and coster services. These folders need to exist.
C:\Program Files\TSC\CALLTRAK\rawdata00

(for site 00)

C:\Program Files\TSC\CALLTRAK\rawdata01

(for site 01)

Etc
Right click on the folders and files and grant full control to all the files in these folders.
After access has been granted, retry starting the CALLTRAK service.

Blank Screen displays after CALLTRAK logon
Error message

After entering the credentials to access CALLTRAK, a blank screen appears and the URL displays
http://192.168.10.69/CALLTRAK/logon.aspx?ReturnUrl=%2fcalltrak%2fdefault.aspx
OR
http://192.168.10.69/CALLTRAK/default.aspx
Operating Systems
Windows Server 2008
Solution
This is an IIS configuration error and needs to be rectified by adjusting the IP addresses and permissions able to
access the CALLTRAK web pages.
Go to the CALLTRAK web site, through IIS (Administrative Tools > Internet Information Services), expand the
options to expose the CALLTRAK default Web site. Right click on the CALLTRAK web page and select properties.
The screen will appear as below. Click on IP Address and access restrictions and add the IP Address(es). Once the
IP Address range are entered, users will be able to access all the CALLTRAK web pages.

The report you requested requires further information
Error message
While trying to generate a crystal report such as report or extension listing, the following error message appears
The report you requested requires further information.

CALLTRAK
Server name:
Database name:
User name:
Password:
Use Integrated Security
Operating Systems
All Windows OS. Windows Server 2008
Explanation
The message appears because Crystal reports can not connect to the database. So, it is important for the following
to occur
Prerequisite
Make sure the correct Crystal reports redistribution is installed including the OS it is intended for. The distribution
downloads can be obtained from
http://resources.businessobjects.com/support/additional_downloads/runtime.asp#07
eg if you have Windows Server 2008, download Crystal Reports Basic for Visual Studio .NET 2008 and select
Crystal Reports Basic for Visual Studio 2008 x86 Redistributable Package (32 Bit)
Eventhough Windows Server 2008 is 64Bit, Crystal reports is a 32 bit application and needs the appropriate 32 bit
redistributables.
Solution
There are 2 causes for this error

Cause 1. Crystal Reports require the ODBC connection properly configured, so that the Web Application
can access the database through the server.
This requires that through the ODBC configuration
ie Administrative Tools -> Data Sources (ODBC)
Not only is there a User DSN entry for the ODBC connection, BUT ALSO a System DSN entry for the connection

Use SQL Server native client, when Configuring the ODBC entry,
A. add a new entry called CALLTRAK
B. when prompted for SQL Server, select the SQL Server name the DB was installed on
C. Tick Connect to SQL Server to obtain default settings for the additional configuration options. You will then be
prompted for the Login ID and Password. Enter the values for connecting to the SQL Server database
D. Click next until the Test Data Source button is displayed. Click the button and if successful, messages will appear
followed by
TESTS COMPLETED SUCCESSFULLY!
E Click OK to complete
Don't forget to create both User DSN and System DSN ODBC entries
For further information, refer to configuring an ODBC Connection.

Cause 2. When installing on Windows Server 2008 (64 Bit), Crystal reports needs to have a 32 ODBC
connection.
Execute the 32Bit ODBC driver found at C:\Windows\SysWOW64\odbcad32.exe
and make sure both the User and System DSN entries for CALLTRAK are created. The ODBC entries are created
similarly to above (Cause 1).

Failed to access IIS metabase
ENVIRONMENT
Win XP Pro (or Virtual server)
PROBLEM
On trying to load the web page ie localhost/CALLTRAK/logon.aspx
The message
Failed to access IIS metabase
The process account used to run ASP.NET must have read access to the IIS metabase (eg
IIS://servername/W3SVC). For information on modifying metabase permissions, please see
http://support.microsoft.com/?kbid=267904
SOLUTION:

Go to the Microsoft.NET (ASP.NET) directory at the cmd prompt ... eg.
C:\WINDOWs\Microsoft.NET\Framework\V2.0.50727
then run
aspnet_regiis -i
This will set permissions and fix the above problem
Retry logging on to the CALLTRAK application. If it still fails, then try the detailed steps below.
FULL DETAILS
1. Unregister all the versions of ASP.NET with command (cmd prompt)
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –ua
2. Delete the ASPNET account from “Local Users and Group – Users”
3. Then register ASP.NET 2.0 with IIS using (cmd prompt)
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –i
4. Give permission to the ASPNET account using
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –ga machinename\ASPNET
5. Reset the IIS and that will resolve the issue

HTTP Error 404
Environment
All
Error Message

On trying to load the web page (Calltrak) ie CALLTRAK/logon.aspx
The message
HTTP Error 404 – File or directory not found.
Internet Information Services (IIS)
error appears
Explanation
By default, Windows Server does not allow aspx pages
Solution
To fix this problem, through Internet Explorer go to
Administrative Tools > Internet Information Services (IIS) Manager
and extend Web Service Extensions.
On the right panel, you should see
ASP.NET v2.0.50727
as an option.
Click on that option and then click the allow button.
If you do not see ASP.NET v2.0.50727 as an option, then asp.net has not been isntalled correctly.
Go to the command prompt
run > cmd
and do to the Microsoft.NET (ASP.NET) directory
cd C:\WINDOWs\Microsoft.NET\Framework\V2.0.50727
cd C:\WINDOWs\Microsoft.NET\Framework\64V2.0.50727
and install ASP.NET v2.0.50727 by

OR
(if 64 bit OS)

aspnet_regiis /i
Then try the SOLUTION as described above and you will see ASP.NET v2.0.50727 as a Web service extensions
option.

CALLTRAK Database displaying CALLTRAK (Read only)
Error Message
This error message may appear when the CALLTRAK database is attached. It occurs when the permissions of the
CALLTRAK SQL Server database file do not have sufficient privileges or permissions. Prior to attempting to attach
the database, please have full access for users in the folder.
Environment
General
Solution
1. Stop the SQL Server service using SQL SERVER Configuration manager. This program option will be found
on clicking
Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager
Clicking on SQL Server Services, on the right panel you will see SQL Server service in a running state. Click the
service, then right click and click stop. The service will stop.
2. Move the calltrak.mdf database and calltrak.ldf file to another temporary holding area
The calltrak.mdf file, by default resides in C:\Program Files\TSC\CALLTRAK\DB
move the two database files from C:\Program Files\TSC\CALLTRAK\DB to C:\Program
Files\TSC\CALLTRAK\hold
3. Start the SQL Server service using the SQL Server configuration Manager. From step 1, Right click the
stopped SQL Server service and click start. Exit the SQL Server Configuration manager.
4. Start SQL Server Management Studio and log in using sa credentials
5. You will see the CALLTRAK (Read only) database name. Delete the CALLTRAK (Read only) database file
by right clicking and then selecting delete
6. Exit SQL Server management studio
7. Copy the Calltrak.mdf database from the holding area back to the DB folder
copy the two database files from C:\Program Files\TSC\CALLTRAK\hold to C:\Program
Files\TSC\CALLTRAK\DB
8. Start SQL Server management studio, log on and you will notice the CALLTRAK database is no longer
there.
9. Attach the calltrak database as described in SQL Server configuration step 1

10. Calltrak database is no longer read only

Crystal Report does not export
Error message
After generating a crystal report, when you try to export the error message
The selected document cannot be opened
Is displayed.
Operating Systems
Any, noticed on Windows 7 Pro
Solution
Need to install adobe reader first.

